What i've tried so far....

Discuss it here

Moderators: Community Moderators, Veterans - RM Community

Forum rules
RM Specific Disclaimer: Users should be advised that any software files, modifications, upgrades, plugins etc are property of the poster.
Xatrix Security do not accept ownership of these files nor do we accept liability for any copyright violations.
Xatrix Community Guidelines: Click Here
Post Reply
dcx_badass
Posts: 3
Joined: Wed Apr 25, 2007 11:15 pm

What i've tried so far....

Post by dcx_badass » Thu Apr 26, 2007 6:29 pm

Well we have a lot of restrictions.
We can't run:
exe's
bat's
msi's
reg's
and more.

We can't download exe's, or run them, even from zip's. We also can't get on sites by IP address, thats a computer restriction, and our internet is controlled by the local council so no chance of getting round that block really, well we all have internet logins for that, so would need a teachers account, but don't really need this anyways.

I can access the main server root using a shortcut, but many folders are locked out to me.
I can load:
"C:\Program Files\Research Machines\Network Management\Web Launch\WebLaunch.exe"
But it needs a login.
This doesn't work, says it doesn't exist.
"C:\Program Files\Research Machines\RM Tutor 2\Controller\TeacherLaunch.exe"

We can't access C:\ not even from word. Teachers can't access the management console(printer credits space etc), but they can give us demo's and monitor and remote control us.

We can use teachers accounts without raising alert, unless someone notices, but its really hard to get these, they keep they're passwords hidden well. Once he knew we were using a teachers account(who was off for 3 months), so set an alert to tell him when we logged on, but someone got caught. Most of the time the password is just randomly changed.

They're moderately strict. Eg. Someone deleted the whole school intranet(as an open day project we could make our own pages about it, and he overlooked the edit button on it, and someone deleted it all). I think they got one after school. Another time, all my work wouldn't save, it said the floppy drive door was open on a HDD, wtf? And they said i couldn't save it, i'd have to lose it all and redo it. So i copied 4000 files into the shared directory(mostly empty txt files and the odd song), two more people did it aswell and did about 2000 each, did this for like 30 mins, he came in pointed at my pc and said come here now, apparently we'd logged up the whole server, serves em right for telling me to loose my work, i got banned from the computers for a month, until they realised it wasn't feasable to ICT GNVQ with no pc access, and i was using friends accounts anyways.

Anyways after that we didn't really do anything, i'm not intrested in doing anything malicious, all i'd really like to do is be able to remote control people's PC's just as a joke to mess around, and to be able to run exe's, just so i can use VLC player to play AVI's, use everest to look at all the pc specs, use podplayer on my ipod so i can access the music on it too listen too, and finally use the U3 launchpad on my memory stick so i can run WLM(msn messenger) off it. Nothing bad.

Also just as a note, we get 30mb, and if you fill it, and need all the work you go upto 100mb(i filled 97mb a while ago) so i just use memory sticks now, not used my area for a while. Each black and white printout is 5 credits, colour is 25, cos i did ICT last year i automatically get 100 credits a week, other people get 100 maybe each term and have to ask for more i think.

Info on the setup just incase anyone is intrested, A Projector and Smart board in every room (about 70), and quite a lot of servers spread around the school, one per ICT room(4), Library, and a few in other class rooms, we have maybe 10.

Thanks.

jd2kuk
Posts: 1537
Joined: Fri Mar 16, 2007 12:19 am
Location: UK

Post by jd2kuk » Thu Apr 26, 2007 9:56 pm

Okayyyyy... from the top

I'll come back to the part about running exe's

As for running rm tutor (Which is used for remote control by teachers), are you sure you're using the right file path there... if you're using rm tutor 3 the file path is completely different. Or, it could be that you don't have permissions on that file, in which case you'll need an account that does.

Running exe's- it looks like most of the loopholes in your school are blocked, so to run exe's, you'll need an account which basically can do just that. Probs need to be an admin

And if you didn't already know (Cos I don't know if you do or not), weblaunch.exe launches all the web based components for rm- learning resources, intranet, management console etc... by default it goes to management console

dcx_badass
Posts: 3
Joined: Wed Apr 25, 2007 11:15 pm

Post by dcx_badass » Fri Apr 27, 2007 1:51 am

Thanks i don't know much about this really, we have search disabled aswell(grrr) so i'll have to manually go through the thousands of folders on the server, i'll do it on monday, thanks.

Post Reply